Error while uploading troubleshooting code


#1

After I finished soldering the headers onto the top face of the LED cube, I tried to upload both sets of troubleshooting code. In addition, I also looked up test code from Arduino and Adafruit, but I still get the same error: exit status 1 error compiling for board. I have tried to find what this error means, but I still haven’t been able to upload any code or get the LED face to light. Can anyone help me?


#2

The “exit status 1” error just means the code couldn’t be uploaded to the board. First check that you’re using the correct interface - under the Tools menu item in the Arduino IDE check that the “Board” is Arduino/Genuino Uno and the “Port” is ComX/(Arduino/Genuino Uno) where X is a valid Com port (e.g., 3). If these are correct, then scroll up in the bottom window of the IDE to see where the compile error occurred.


#3

I tried your solution and was able to get rid of the “exit status 1” error, but now I get a message that there was an error while uploading the sketch. More specifically, the error looks like this: avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x30. Is there a way to fix this?


#4

That error usually happens when you have the wrong COM port selected or your Arduino isn’t recognized by your computer. Double check that you have the USB cable connected to a working USB port on your computer and that you have select your Arduino from the Port: menu.


#5

All three of the USB ports available in my computer give me the same one option for a port: COM3. Do you know of any others ways to help the computer recognize the board?


#6

Did you read any of the early posts where there was a problem with the 5v/3.3v switch on the Uno board? Try sliding the switch back and forth a few times and then leave it in the 5v position.