General Discussion

official

#1

General discussion of the LED Cube module.


#2

where is the thimble store located, how do i go about getting the 6DOF IMU


#3

Has anyone put the LED kit together? With as much chatter as there was with the wifi robot, I’m surprised there’s nothing yet.


#4

Perhaps there’s no chatter yet because the kit was shipped without a (optional) part that is needed before you can assemble the kit?

It would really have been nice to know I was getting an incomplete kit. This cube was designed with this part in mind, and yet MONTHS after waiting for shipment, and then a longer wait to get the instructions, NOW we learn that there is something missing that needs to be ordered separately.

And contrary to the instructions and videos, it is NOT available to order in the store.


#5

Yeah, the parts store isn’t up yet. Maybe they haven’t finished testing it? I imagine it’ll be up soon.

Did you back the kickstarter? You seem to have been around Thimble for a while. I missed the kickstarter but joined back in August I think to get the first kit. I’m looking forward to these kickstarter/startup bumps to smooth out, especially with shipping. I think the 3rd and 4th kits will really be important for keeping promises.


#6

Hi Guys, just wanted to say that I have built the cube and I am playing with the code, trying out different lighting and colour patterns. Have it doing the dice roll thing as I write this.

I am waiting for the 6DOF IMU like everyone else, but I’m not letting that stop me from being creative. With board 6 I only soldered the 3 electrical connections on the one side and not the 6 other structural connections on the opposite side. See image below.


I can de-solder the 3 connections with the help of my solder sucker easily and remove the bottom board, this will allow me to easily insert the 6DOF IMU board when it comes. You might also note that I still have the shield board from the wifi bot mounted on my Arduino, this allows me to continue to run the program with the cube without needing it to be connected to the PC for power.

I also used a small section of straight header(4 pins long) to help me evenly space the bent headers out from the boards on the sides of the headers that had the long pins. You can see in this picture the four pin section slipped in under the left hand header.


I have found this gives me a nice even length to both sides of the header that squares up the corners nicely.
A little tip I found with cutting headers, if you don’t have a nice set of side cutters, you can always use nail clippers for doing your finger or toe nails :wink:

Cheers
Coyote


#7

I’m holding off on assembly until I get the 6DOF IMU board, but I also ordered some female headers. I’m hoping I can make the cube a press-together instead of a solder together. That way I can open it up and modify it later. Thinking of maybe getting an Arduino mini if it fits inside, and maybe a small battery module to power the whole thing, so it will be stand alone. We’ll see how the coding phase goes first.


#8

I was thinking the same thing!


#9

#10

I’d really like to see improved/more explicit instructions for these kits. I feel like the written instructions are sometimes lacking. I usually watch through the video to get an idea of what’s involved, but then prefer to use the written when actually constructing. I’ve found that I really have to go back into the videos during the construction phase, because there’s usually some piece of info that’s just not there. In particular, on this project, I failed to notice the different orientation of the headers for board 6 in the images, and the video made no mention of the different orientation. Long story short, my cube will never actually be a cube now.

I’ve also been stuck hunting down the libraries needed for the example/test codes when searching via library management in Arduino doesn’t turn up the necessary files. This happened to me on both projects. Please provide the links to these in the instructions page. The code examples could use expanded instructions as well. I got compiler errors for the motion sensing test (after finding and installing the proper libraries, and un-commenting the calibration section). I never did figure out why it wasn’t working. Though to be honest, I figured I’d come back to it after completing the cube.

My main issue is that I though there would be more education and learning built into the the kits. The background information at the start of each project is great, but there’s a lot that’s glossed over on the coding and integration side once we’re in the actual projects.


#11

For the cube not actually being a cube, it’ll take some time but you should be able to remove and then reverse those headers with a solder sucker or solder wick. I messed one up too but was able to fix it. Pain in the butt, but it worked out ok.

As for the schematic, I agree. The wifi robot got a lot more attention, I think because it was the first kit. The flagship, if you will.


#12

Yeah. I was able to get two of them back off, though I still need to get the rest of the solder back out of the actual holes. The issue of not moving forward beyond this is more a question of the little free time I have available right now. I probably won’t have time to even look at it again until June or July. :wink:


#13

Do you have a suggestion on how to make this more obvious? I can add a textual call-out, but I was really hoping that diagram would make it very obvious what the orientation is.


#14

Yeah. I think just a quick line reminding that there’s a different orientation would be very helpful. Also, I think bringing the text instructions more in line with the isntructions contained in the video would be helpful. Like I mentioned, I’d prefer to follow just the text instructions while I’m actually constructing, but the video instructions felt more complete. So I found myself focusing on that, and there was a better demonstration of the header orientation for the other boards with no mention of the necessary change for the 6th board.


#15

Got it, thanks! Our new video production process should close that loop between text and video instructions and make sure they are both in line.


#16

Something else I’ve been thinking about are images of the technical drawings. They seem to have a transparent background, which means they end up on a field of black when I open them in my browser. That makes them hard to read in the enlarged state. It would be awesome if you could slap a white background in them. GIMP is a good piece of open source software, similar to Photoshop, that would allow you to do this pretty easily.


#17

I finally got some time to put my Thimble LED cube together. The build wasn’t too bad and some of the examples and submitted code is mesmerizing to watch. The biggest problems I ran into was getting the cube to piece together nicely after soldering the headers, understanding the instructions for wiring up the MPU6050 (6DOF IMU), and programming the optional board.

When I was soldering the headers to the individual boards, I laid them out as diagrammed and positioned the headers as shown. Where the black part was sticking out, I soldered the rest with the long pins flush to the board. Wrong! The boards didn’t fit together. I had to heat the solder back up and push the headers down some. I didn’t have to mess with board 6. It was already right. After that, they fit together beautifully, with a perfect gap in between each board. I would suggest soldering the short pins first so you can more easily figure out the spacing on the long pins.

Wiring up the 6DOF IMU was giving me some grief because I still consider myself a newbie to Arduino and still am not too familiar with what each pin is called. I had to go over the instructions and video several times trying to figure out what was being said and where the yellow and green wires go. It looks like in the video there was one unused pin at the end of the row, but what finally worked for me was moving the yellow and green pins over so there were no unused pins. That was my only wiring issue.

The third issue was running the demo program for the MPU6050. Mostly, it was the wiring problem previously mentioned, but the Arduino IDE was throwing up some errors/warnings. One of the warnings can be fixed following the directions on GitHub. I wasn’t able to find a fix for the other warnings. The code seems to upload and run ok.