Problem Uploading To Board


#1

I am trying to use this for the first time. I am following the instructions, but when I try to upload the Blink example code, this error pops up:
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
I have tried two different cables and two different boards and shields. I am not sure what to do!


#2

Sorry to hear that there are issues. It’s very common to run into some the first time you start using Arduinos. Can you tell me a bit more about the errors? In the pictures i’ve included, you can drag that console window up to reveal some more info. If you post a screenshot or press the Copy Error Messages button then paste that into a post. Either of those would help me figure out whats going on.



#3

Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Uno”

C:\Users\mikem\Documents\Arduino\sketch_dec05a\sketch_dec05a.ino:2:21: fatal error: rgb_lcd.h: No such file or directory

#include “rgb_lcd.h”

                 ^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


#4

Double check that you have the rgb_lcd library installed from the libraries section.


#5

I am having trouble uploading to the board. I keep getting an error message. Here is my message.

Arduino: 1.8.5 (Windows 7), Board: “Arduino/Genuino Uno”

Sketch uses 2180 bytes (6%) of program storage space. Maximum is 32256 bytes.
Global variables use 52 bytes (2%) of dynamic memory, leaving 1996 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x5a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x5a
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Any help would be greatly appreciated. Thank you.