Problems with LED Cube Instructions - advice for others new to Thimble


#1

I have just received my first kit and have a lot of issues with the instructions provided. Where I have a solution I give it here - for my latest problem I am hoping for feedback from other members.

  1. Volume is too low. I am playing the video’s on an iPad Pro which has good sound with the volume at maximum and I can barely hear what the demonstrator is saying.

  2. Too much video of soldering. We get it - this kit has a lot of soldering - but the important thing I need to see in the video is WHAT to solder WHERE. The actual soldering has no value to me.

  3. What to Solder Where. The guy in the video never says how many pins to clip off from the header pin strip although you can figure it out. He never mentions how important it is to get the right part of the right angle in the right card - I bet half you users soldered it in reversed. He never highlights which pins connections are purely mechanical (and so would be good for practising) and which are electrical (and must be good quality). Frankly the videos were almost useless.

New Users: Pay careful attention to the board layout near the top and note which way round the right angled headers fit - ie which boards have the black plastic bit sticking out at the sides.

  1. Schematic. As soon as the top board is done we connect to the Arduino board. Again - he rushes the connections with a reference to the schematic (which does not exist). Then we are given some code.

  2. Arduino IDE. Wait - code? I have not seen any way to load code onto the board. Only after searching Learn, Help and Forums did I finally find a link to the Arduino website on the intructions for the previous kit (robot) which I did not get. Why is this not even mentioned on the LED Cube instructions?

[New users: You need to download the Arduino IDE from here: https://www.arduino.cc/en/Main/Software]

  1. Missing Library. I then connected the board, ran the IDE and pasted in the code that had been provided. I saved and then tried to upload. It failed with a cryptic (if you are not a C programmer) error message regarding a missing library: Adafruit_NeoPixel

[New users: I did some googling and downloaded the library from here: https://github.com/adafruit/Adafruit_NeoPixel
Then I moved the (unzipped) folder into ~/Documents/Arduino/libraries on my Mac and much to my surprise it solved the problem. The location of your Arduino folder may be different.]

  1. Missing Device. Now I got a new error saying my board was not found.

Under Tools -> Board it seemed to be detected and selected but I found it was not selected under Tools -> Ports so I selected my USB port and reloaded - this time I got all the LED’s on my top board lighting brightly.

  1. Second Board Does Not Light. I soldered the top board to Board 2 and retested. The top board still lights but the second board does not. There are ZERO troubleshooting steps at this point - in fact there is an irritating amount of information and help devoted to the optional motion sensor that I was not even told about but no help on how to test boards 2 through 6, where to connect the remaining wires beyond the first 3 or what to do if a board does not light.

a) I have inspected and improved the solder.
b) I have checked connectivity across my connection (out on top to in on 2)
c) I have checked connectivity from out on top to the other in on the left side of 2 - which means the circuits are connected across the board.
d) I have checked 5V when powered on both of the + lines.

I dont know what to do next. I bought this kit to teach my kids the you of creating things and they have returned to their iPads in disgust. This was not what I signed up for.


Newbie question - uploading code
#2

Hi Ewan - thanks for sharing your feedback here. I feel your frustration and I’m really sorry! We will do everything we can to make sure your cube gets soldered and programmed correctly. I’ve reached out via email to see whether we can jump on a call/Skype with you tomorrow. I’ll have a couple members of my team with me on the call to see what the problem is and check to see whether we need to send any replacement boards.

Making the instructions better and easier to understand is a high priority for us. Thanks to the community here on the forums, we’ve heard a lot of feedback on ways we can improve. We’ll make sure we keep this thread updated so others can know how we solved the obstacles presented above. Thanks Ewan!

Oscar


#3

Outstanding customer service - and on a Sunday too!

I will try another board in place of number 2 first to see if anything changes.


#4

RE: Second board doesn’t light.

Did you get it figured out? If the second board doesn’t light make sure you change the code in strandtest-1.ino on line 10 from 16 to 32 pixels for two panels. Change to 96 to get the entire cube to light.


#5

I was going to write my feedback about the LED cube and was going through the forum to see if others experienced the same issues as me. You have covered every issue that I faced with the videos (volume being too low, not telling which joints are just mechanical and which are electrical). You showed the numbering but it was important to highlight the data flow and to make sure during soldering that the data was flowing from one board to another. My 12 yr old son did the soldering and he got it wrong. The instructions need to be much better and clear. If we get it wrong it’s very difficult to fix things due to the solder.


#6

Hi Oscar,

I am a new member and faced all the same issues that Ewan did. Unfortunately my code is all connected wrong and only 3 sides are working. I wish I had read Ewan’s comments before. Can you please provide some help ? It’s very disappointing as I have just started and things are not working. I tried to unsolder things today but it’s not coming off easily and I am worried I might break something.


#7

Hi there user36587,

Sorry to hear that you’re having problems with the LED cube. Can you shoot me a note at support@thimble.io? I will be able to better assist you offline so I can better understand where to help. If we need to, we can send replacement boards so you can finish soldering the cube correctly. Thanks!

Oscar