USB to serial converter sometimes very hot


#1

I’m running the LED Cube at work (link), because it’s neat. So it’s on for hours each day.

I’ve noticed that sometimes the USB to serial converter (the yellow highlighted part) gets very hot, like it burns your finger when you touch it.

It doesn’t happen all the time, and I have no idea why it would happen just some of the time. I can have the cube running for 8 hours, and it’s cool to the touch. Other times after maybe 20-30 minutes, it’s super hot.

I’m powering the cube from one of my laptop dock’s USB ports with the cable that came with the board.

Some questions:

  1. Has anyone else experienced this?
  2. Does anyone know why it would happen?
  3. Does anyone know why it wouldn’t happen all the time, but just sometimes?

I’ve tried searching for issues related to this, but can’t find anything that makes any sense to me.


#2

Does this happen while programming the LED cube or just after running it for a while? Do you have the serial console open on the computer or any active communication going on?


#3

I’ve only noticed after running it for a while, but like I said it’s not every time. That’s the weird part to me. Yesterday morning it was running hot, so I unplugged it while I was away from my desk (in case a fire started). But the afternoon 4 hours it ran nice and cool without me doing anything.

I don’t have the serial console open, but am otherwise doing normal work on my laptop. Not sure if Windows or something else would keep checking on that USB port? That’s a big unknown to me. I suppose I could try powering it from a wall plug instead of leaving it on USB power all day. I haven’t tried that yet.


#4

The reason I asked is because I have found that I can put this board into a “bad state” by opening the serial console and hitting the reset button. Doing this shorts the reset channel through the USB to serial chip, making it hot as you are describing. I’ve spoken with the manufacturer about this and it is a firmware issue with the USB to serial chip. They aren’t planning to fix it though, as they see it as an edge case that is easily remedied. I do agree that it is an edge case, but I don’t like that it can happen. In response to that, I’ve been evaluating other options for a supplier. It’s tough because there are many other features of this board that I see as superior to other options, but I have found a couple that do seem reliably better.

As you found, if you just hard reset (disconnect power), it will function again. However, I’ve only seen symptom when there is a serial connection through the arduino IDE and the reset button is hit.

That said, we’ve run the LED cube for multiple days off both laptop/computer USB ports and off wall plugs and haven’t had any problems.


#5

Ok, so it does sound like just a problem with the USB to serial firmware. So at least it’s nothing I’ve probably done :slight_smile: Thanks for the info!